Welcome to Altis Life RPG

Register now to gain access to all of our features.
Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more.


Note that you can now sign-in with your Steam account.


This message will be removed once you have signed in.

  • Announcements

    • AltisLifeRpg

      Opening Announcement   09/13/2016

      Opening Announcement We are happy to announce the official reopening of the community assistance forum Altis Life RPG (open source public property). Before going any further, let's go over the current situation. As you are already aware, the forum and the database of Altisliferpg.com had been hacked a few weeks ago. This unfortunate situation has touched many communities of Arma 3. The various databases were erased, and since they were under the responsibility of the previous administration, no backup was able to recover the lost data. This means that all the tedious work must be redone. This regrettable situation has led Tonic to transfer the responsibility of its administration to a new and neutral party. This party has as sole goal to reunite every community, as diverse as they are, together to perpetuate the development of our beloved mod AltisLifeRPG.  First of all, I think it is important to clarify our intentions. Foremost, we want to reassure you that we are not proclaiming being the owners of the previous versions of Altis Life (open source public property) in collaboration with BoGuu based on Tonic' codes. As you know, Boguu has been a major player in the most recent versions. Please note that this platform is and will always remain open to future developers such as Boguu that would like to elevate Altis Life RPG to the next level. By doing so, we take our role as an official reference platform very seriously in the eyes of the vast community of Altis Life RPG. We are ready to face this responsibility. We are aware that the content added by users could be provided by external sources or from the original website. If you see a tutorial that you've created on our platform where you are not credited as the author, please mention it immediately to the administration and we will promptly fix the situation. Please note that seeing the overwhelming amount of content added by the community, we will not proactively search other community assistance websites to validate if proper credits were given to the various authors. Instead, it will be the author's responsibility to be proactive in contacting the administration. Since the majority of the content found on other websites came originally from Altisliferpg.com, we encourage members joining us to share any content deemed pertinent coming from other platforms without forgetting to credit the authors.       Finally, to clarify the rumors circulating: - The forum was not scammed. It was transferred directly from Bryan 'Tonic' Boardwine to our administration. A domain cannot be scammed. - The forum was transferred as an independent entity which has as a sole mission to perpetuate the forum and not let it die out.       Altisliferpg.com Regards, the Administration.       Feel free to join us on Discord in the Altis Life RPG Community section of the forum.   And of course if you have any question, feel free to message us here.
    • Rozo

      Donations   09/18/2016

      Hello,
        We've added a donation block on the right side. All of those donation goes directly to the developer of Altis Life mod ( currently BoGuu ). None of that money is used to maintain the forum. In the future we might add a donation button to support the forum, but for now we want to encourage the developer because they went through a lot. To discuss this topic - Here
    • Shakir Darwish

      IS YOUR SERVER BROKEN SINCE 1.64 UPDATE?   09/22/2016

      If your server is broken since 1.64 go check this link thanks. https://github.com/AsYetUntitled/Framework/issues/104
    • Rozo

      Sad Day   01/04/2017

      Good evening community of Altis Life RPG, Today was a sad day. We learned the hard way that one of the helper was using his status and visibility on the forum to do things i wouldn't imagine.  We were warned about this user in the beginning, we talked about his behavior and he said that they were things of the past. We were fooled.
      Unfortunately, he fooled other community members by selling stolen content and impersonating his role as a developer in another community. Here's a remember of one of the rules on our forum, No selling scripts, snippets, or services.   So if anyone come across someone who's selling his services, scripts or whatever, Report them. Especially if it's coming from an Helper, Mod, Admin. No one in the staff should ask for money, we already mention this when we reopened the forum and that rule is here to stay.

      We can't be sorry enough for what happen here, for any harm it as caused among other communities, for money that shouldn't been spent and we truly hope this doesn't happen again.

      As for the user in question, he is now banned from our forum and discord and we wish to never cross his path again.
        If there's anything we can do hit us on Discord or send a message to an admin.
      Thanks, Rozo.
ApexNetwork

Windows key does not work at all?

30 posts in this topic

__________________________________________________________________________________________________________

In a short sentence, what kind of Issue are you having: Everyone including admins are unable to use the window key at all, no functions will work when pressing it.

What would you say is your understanding of SQF and or SQL on a scale of 5/10: 7/10

Do you understand that if your issue is solved we suggest that you add a "Solved" reply to your topic?: Yes

You must include log files(RPT/extDB), and your Altis Life framework version with your topic:

RPT: https://pastebin.com/waiHfwNb < There is also a bunch of errors in there, if you know how to solve any please hmu! :)

extDB3: https://pastebin.com/mZN7Q3FK

Altis life 5.0.0

 

____________________________________________________________________________________

Edited by ApexNetwork

Share this post


Link to post
Share on other sites

Just from looking through some of the RPT.

 

I noticed this line: Undefined variable in expression: bank_obj
In you're mission.sqm, did you move the "Land_Garbage_line_F" on spawn island named: bank_obj? 

It looks like this: 
G5q0SHE.jpg


Add that to your map, and it should fix the issue.

In regards to the rest of the RPT. It looks fine, it's just infistar shit.

Edited by NothingToSay
  • Thanks 1

Share this post


Link to post
Share on other sites

Give us your client side logs. I don't know why they don't mention that in the post that you're supposed to model after.

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, Maihym said:

Give us your client side logs. I don't know why they don't mention that in the post that you're supposed to model after.

There is no point really. Because bank_obj gets called from 1 file in the entire mission.  He has ported over to Malden, and forgot the bank_obj item. Its blatantly obvious.

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites
Just now, NothingToSay said:

There is no point really. Because bank_obj gets called from 1 file in the entire mission.  He has ported over to Malden, and forgot the bank_obj item. Its blatantly obvious.

I really don't think that's whats causing the windows key to not work.

  • Like 1

Share this post


Link to post
Share on other sites
Just now, Maihym said:

I really don't think that's whats causing the windows key to not work.

/* Map-based server side initialization. */
master_group attachTo[bank_obj,[0,0,0]];

His client RPT wont tell him anything. Because the above is server side only. Not client.

  • Like 1

Share this post


Link to post
Share on other sites
Just now, NothingToSay said:

/* Map-based server side initialization. */
master_group attachTo[bank_obj,[0,0,0]];

His client RPT wont tell him anything. Because the above is server side only. Not client.

The windows key is assigned in the fn_keyhandler file in his mission file. It not working is most likely due to an error in that file but we won't know that without his client side logs. Most if not all errors in his mission file will appear in his client side rpt logs not his server logs. Errors with the database are with his extdb logs and errors withing the life_server are in the server side logs.

  • Like 1

Share this post


Link to post
Share on other sites
11 hours ago, NothingToSay said:

Add that to your map, and it should fix the issue.

This won't solve the issue, although it will fix that specific error. Please upload a copy of your client side RPT after pressing windows key or user action key 10 in game.

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, Shane Prat said:

This won't solve the issue, although it will fix that specific error. Please upload a copy of your client side RPT after pressing windows key or user action key 10 in game.

 

10 hours ago, Maihym said:

The windows key is assigned in the fn_keyhandler file in his mission file. It not working is most likely due to an error in that file but we won't know that without his client side logs. Most if not all errors in his mission file will appear in his client side rpt logs not his server logs. Errors with the database are with his extdb logs and errors withing the life_server are in the server side logs.

 

10 hours ago, NothingToSay said:

/* Map-based server side initialization. */
master_group attachTo[bank_obj,[0,0,0]];

His client RPT wont tell him anything. Because the above is server side only. Not client.

Hey guys, thanks for all the help your giving :) Here is the client RPT:

https://pastebin.com/tNTZeba1

Edit:

Here is the fn_keyHandler.sqf file:

https://pastebin.com/0LusmWat

Edited by ApexNetwork

Share this post


Link to post
Share on other sites

Post your actionkeyhandler file. Here is your error:

15:57:59   Error Type Array, expected Number
15:57:59 File core\functions\fn_actionKeyHandler.sqf [life_fnc_actionKeyHandler], line 124
15:58:00 Error in expression < {player distance _curObject < 12} || ((nearestObject [_pos,"Land_Dome_Big_F"]) >
15:58:00   Error position: <nearestObject [_pos,"Land_Dome_Big_F"]) >

 

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Maihym said:

Post your actionkeyhandler file. Here is your error:


15:57:59   Error Type Array, expected Number
15:57:59 File core\functions\fn_actionKeyHandler.sqf [life_fnc_actionKeyHandler], line 124
15:58:00 Error in expression < {player distance _curObject < 12} || ((nearestObject [_pos,"Land_Dome_Big_F"]) >
15:58:00   Error position: <nearestObject [_pos,"Land_Dome_Big_F"]) >

 

 

1 hour ago, ApexNetwork said:

Here is the fn_keyHandler.sqf file:

https://pastebin.com/0LusmWat

 

Share this post


Link to post
Share on other sites
1 minute ago, ApexNetwork said:

 

 

Wrong key handler, I need the fn_ACTIONkeyhandler file

  • Like 1

Share this post


Link to post
Share on other sites
5 minutes ago, ApexNetwork said:

Your error is somewhere in here but I believe it's caused by the _pos variable right about this code.

 

if (_curObject isKindOf "House_F" && {player distance _curObject < 12} || ((nearestObject [_pos,"Land_Dome_Big_F"]) isEqualTo _curObject || (nearestObject [_pos,_vaultHouse]) isEqualTo _curObject)) exitWith {
    [_curObject] call life_fnc_houseMenu;
};

 

  • Like 1

Share this post


Link to post
Share on other sites
9 hours ago, NothingToSay said:

/* Map-based server side initialization. */
master_group attachTo[bank_obj,[0,0,0]];

His client RPT wont tell him anything. Because the above is server side only. Not client.

If you have no idea what you are talking about please don't give people false info, I suggest you go to BIS and learn the difference before client and server. 

Share this post


Link to post
Share on other sites
1 hour ago, Maihym said:

Your error is somewhere in here but I believe it's caused by the _pos variable right about this code.

 


if (_curObject isKindOf "House_F" && {player distance _curObject < 12} || ((nearestObject [_pos,"Land_Dome_Big_F"]) isEqualTo _curObject || (nearestObject [_pos,_vaultHouse]) isEqualTo _curObject)) exitWith {
    [_curObject] call life_fnc_houseMenu;
};

 

Is this code fixed? Or are you just telling me that it's wrong/broke?

Thanks!

Share this post


Link to post
Share on other sites
2 minutes ago, ApexNetwork said:

Is this code fixed? Or are you just telling me that it's wrong/broke?

Thanks!

I'm just telling you what's wrong, I'm not exactly sure how to fix it without testing it myself.

Share this post


Link to post
Share on other sites
1 hour ago, Maihym said:

I'm just telling you what's wrong, I'm not exactly sure how to fix it without testing it myself.

Hmm, me either. Anyone have any clue?

Share this post


Link to post
Share on other sites
3 minutes ago, ApexNetwork said:

Hmm, me either. Anyone have any clue?

How many servers are you running and with what map?

Try this, I changed the way _pos was being set.

https://pastebin.com/FCWJmThn

Edited by Maihym

Share this post


Link to post
Share on other sites
28 minutes ago, John Meiers said:

If you have no idea what you are talking about please don't give people false info, I suggest you go to BIS and learn the difference before client and server. 

Can you edit Repentz's post and mention to upload server and client side logs.

Share this post


Link to post
Share on other sites
11 minutes ago, ApexNetwork said:

I am running 1 server and it is Malden. Running Atlis life 5.0

Ok well try replacing the code I put in the pastebin with your current actionkeyhandler and let me know what happens.

Share this post


Link to post
Share on other sites
23 hours ago, Maihym said:

Ok well try replacing the code I put in the pastebin with your current actionkeyhandler and let me know what happens.

still not working bud, someone told me it was to due with the fed not being put in the malden map, I changed it and added the correct cords but it still is not working? Please can someone help?

Share this post


Link to post
Share on other sites

You need to edit all instances of where the terrainsort function is. Turning on script errors may also help you. 

  • Thanks 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.