Jump to content
Hotokuken

AltisLife Port to Takistan - Spawns not working

Recommended Posts

Hello,

I recently did some testing and with the vanilla 5.0.0 framework on the Takistan map and doesn't allow spawn selection. The window appears to select a location but there are no entries. I have confirmed that all editor entities have transferred over to the new map. I have also tried to create a test_spawn and added the entry to the Config_SpawnPoints.hpp.
 

Just to verify the steps taken.

1. Downloaded v5.X.X from https://github.com/AsYetUntitled/Framework

2. Set everything up as instructed. 

3. Grabbed the Altis_Life.Altis folder and missionAltis.sqm.

4. Disabled SpyGlass in Config_Master.hpp

5. Uploaded to my server. 

6. Verified the Altis_Life.Altis file worked and I was able to connect and spawn in. 

7. Renamed Altis_Life.Altis to Altis_Life.Takistan

8. Re-uploaded to server and relaunched. 

9. Connected and tried to spawn - ISSUE OCCURRED

10. Spawned at location on N side of map. No spawns selection options.

11. Edited mission.sqm to include test_spawn empty marker. 

12. Edited Config_SpawnPoints.hpp to include test spawn

13. Re-uploaded and re-tested - Issue Still occurred.

Attached is my RPT file from the server. 

 

https://pastebin.com/G8m2Kd2Q

Share this post


Link to post
Share on other sites

https://pastebin.com/7n2h9p6z

I see the server --> Connect --> Pick a slot --> It shows the Altis Life 5.0.0 Loading Picture --> loads me in with spawn selection screen but there are no options to spawn --> Click spawn and I assume it spawns me into the actual location of the unit placement on map. 

Share this post


Link to post
Share on other sites

I found this in the client RPT file

22:38:06 Error in expression < displayCtrl 38502),1,0.1,getMarkerPos (_sp select 0)] call life_fnc_setMapPosit>
22:38:06   Error position: <_sp select 0)] call life_fnc_setMapPosit>
22:38:06   Error Undefined variable in expression: _sp
22:38:06 File dialog\function\fn_spawnMenu.sqf [life_fnc_spawnMenu]..., line 34

 

However, when I compare my fn_spawnMenu.sqf to the one in the original 5.X.X framework it is identical. 

Share this post


Link to post
Share on other sites
On 6/1/2020 at 3:54 AM, Hotokuken said:

I found this in the client RPT file

22:38:06 Error in expression < displayCtrl 38502),1,0.1,getMarkerPos (_sp select 0)] call life_fnc_setMapPosit>
22:38:06   Error position: <_sp select 0)] call life_fnc_setMapPosit>
22:38:06   Error Undefined variable in expression: _sp
22:38:06 File dialog\function\fn_spawnMenu.sqf [life_fnc_spawnMenu]..., line 34

 

However, when I compare my fn_spawnMenu.sqf to the one in the original 5.X.X framework it is identical. 

Send your Config_SpawnPoints.hpp pls

 

 

Edited by Jeff Khali

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.