Jump to content

doMove with AI in Life not working

Recommended Posts



i am working on a tutorial script for my life server. A bot should move from Point A to B. It works really nice in Singleplayer, but not in Multiplayer (on the life server).

I tried to call, spawn and execVM the script. All with the same result. The bot just stands there.

player setPos (getMarkerPos "spawnpoint_tutorial_player_1");
_meters = player distance getMarkerPos "spawnpoint_tutorial_NPC_1";
_group = group master_group;
_smuggler = _group createUnit ["C_man_hunter_1_F", (getMarkerPos "spawnpoint_tutorial_NPC_1"), [], 0, "FORM"];
_group allowFleeing 0;
_smuggler disableAI "move";
_smuggler disableAI "path";
_smuggler allowDamage false;
_smuggler disableAI "AUTOCOMBAT";
_smuggler disableAI "AUTOTARGET";
_smuggler disableAI "TARGET";
_smuggler disableAI "COVER";
_smuggler disableAI "FSM";
_smuggler disableAI "TARGET";
_smuggler allowFleeing 0;
Civilian setFriend [west, 1];
Civilian setFriend [east, 1];
_smuggler setBehaviour "CARELESS";
_check1 = true;
 while {_meters > 4 && _check1} do {
 _meters = player distance getMarkerPos "spawnpoint_tutorial_NPC_1";
 _check1 = false;
playSound3D ["A3\Sounds_F\sfx\alarm_independent.wss", _smuggler]; 
sleep 5;
 _smuggler enableAI "move";
 _smuggler enableAI "path"; 
_smuggler doMove (getMarkerPos "spawnpoint_tutorial_waypoint_3_1");

I hope you can help me




Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.