Jump to content
Kureo

[5.0] New Progress HUD

Recommended Posts

Authors: Kureo & Zalac

Updated by: Kureo

Difficulty: Easy

Version: Tested on 5.0 (Could work on 4.4)

(special thanks to @Danny by Daylight)

 

HUD.png.384b1689645997c8cc8cf2aab15b0b65.png

 

 

How to install the new_HUD:

 

Step 1: Download the new_HUD folderDOWNLOAD HERE

 

Step 2: Go to core/functions and replace (fn_hudUpdate.sqf) and (fn_hudSetup.sqf) with fn_hudUpdate.sqffn_hudSetup.sqf, in new_HUD folder!

 

Step 3: Go to dialog folder and put in the new_HUD.hpp file

 

Step 4: Go into description.ext and put under Class RscTitles, this 

#include "dialog\new_HUD.hpp"

comment 

//#include "dialog\hud_stats.hpp"


Step 5: Go into dialog folder, open MasterHandler.hpp and 

#include "new_HUD.hpp"

comment

//#include "hud_stats.hpp"

 

Step 6: Put the icons in my folder into the icon folder

 

Step 7: Go to init.sqf, under 

} count ["gang_area_1","gang_area_2","gang_area_3"];

paste this

while {true} do {
sleep 1;
[] call life_fnc_hudUpdate;
};

 

*UPDATED: (new_HUD.hpp) and (fn_hudUpdate.sqf)

Enjoy!

Edited by Kureo
Updated
  • Like 3
  • Thanks 1

Share this post


Link to post
Share on other sites
12 minutes ago, ValdemarL said:

Check up on Step 7: you type "fn_bankTransfer.sqf" two times

 

:)

Thanks :D

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, ValdemarL said:

Btw the dialog first show when i use a bandage do you know how to fix so it its there when i first spawn in?

I've updated the post, redownload the new_HUD folder and follow step 7

Edited by Kureo
  • Like 1

Share this post


Link to post
Share on other sites

When i'm connect i crash and i had error
 

18:24:03 Warning Message: Resource title new_HUD not found i rename Zazza1 new_HUD

Share this post


Link to post
Share on other sites
16 hours ago, XtayLoL said:

Can't find the count on init.sqf

Than past this:

while {true} do {
sleep 1;
[] call life_fnc_hudUpdate;
};

before this

diag_log "----------------------------------------------------------------------------------------------------";
diag_log format [" End of Altis Life Server Init :: Total Execution Time %1 seconds ",(diag_tickTime) - _timeStamp];
diag_log "----------------------------------------------------------------------------------------------------";
Edited by Kureo
  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...