Jump to content
Fr3x

"There isn't a Vehicle near the NPC"

Recommended Posts

Hey everyone, i recently started to make and config a Altis Life server fro Arma 3 and it as everything good.. but when i buy a Modded car in the Car Shop i cannot put it on the Garage! and when the server reboot is not there.. someone can help me? plz? Thanks!

Share this post


Link to post
Share on other sites

Send your Client and Server RPTs from when you tried it (for the not showing after reboot mainly).

As for storing, it sounds like your modded cars aren't considered Air/Car/Ship via the config, so they don't store.
Add their classes, or their base class, to the list here: https://github.com/AsYetUntitled/Framework/blob/master/Altis_Life.Altis/core/actions/fn_storeVehicle.sqf#L13

Share this post


Link to post
Share on other sites
9 hours ago, imthatguyhere said:

Send your Client and Server RPTs from when you tried it (for the not showing after reboot mainly).

As for storing, it sounds like your modded cars aren't considered Air/Car/Ship via the config, so they don't store.
Add their classes, or their base class, to the list here: https://github.com/AsYetUntitled/Framework/blob/master/Altis_Life.Altis/core/actions/fn_storeVehicle.sqf#L13

Ehhhh.. i don´t know if the modded cars are classes or bases?  But there is a pastebin of mine fn_storevehicle

https://pastebin.com/kAMKTx2n

Share this post


Link to post
Share on other sites
10 hours ago, Fr3x said:

Ehhhh.. i don´t know if the modded cars are classes or bases?  But there is a pastebin of mine fn_storevehicle

https://pastebin.com/kAMKTx2n

As I said, you would add the class or base class (base classes are classes that contain other classes, just like you see in my link, "Air" isn't a vehicle's class) to the line I linked.

Share this post


Link to post
Share on other sites
2 hours ago, imthatguyhere said:

As I said, you would add the class or base class (base classes are classes that contain other classes, just like you see in my link, "Air" isn't a vehicle's class) to the line I linked.

So as you say, i need to put the car name? or class? but wich is the class? how i know?

Share this post


Link to post
Share on other sites
41 minutes ago, Fr3x said:

So as you say, i need to put the car name? or class? but wich is the class? how i know?

Not sure what you mean by "Car Name", but no you wouldn't put the display name of the vehicle in there. Classes, like you would put in config_vehicles or exist for any item. Ex: https://community.bistudio.com/wiki/Arma_3_CfgVehicles_WEST

Share this post


Link to post
Share on other sites
1 minute ago, imthatguyhere said:

Not sure what you mean by "Car Name", but no you wouldn't put the display name of the vehicle in there. Classes, like you would put in config_vehicles or exist for any item. Ex: https://community.bistudio.com/wiki/Arma_3_CfgVehicles_WEST

Yeah, i was talking about that, like if i have i bmw mod the name would be probably as an example car_bmw something like that right?

Share this post


Link to post
Share on other sites
Just now, Fr3x said:

Yeah, i was talking about that, like if i have i bmw mod the name would be probably as an example car_bmw something like that right?

It can be whatever they decided to make it.

Share this post


Link to post
Share on other sites
45 minutes ago, Fr3x said:

Yes, so where i put the class of the car?

I told you that first:

On 2/19/2019 at 1:10 PM, imthatguyhere said:

Click the link.

Share this post


Link to post
Share on other sites
28 minutes ago, imthatguyhere said:

So then you know the exact line in that file you need to add your classes to.

Ok, so like ["Car","Air","Ship" , etc.. ? right?

Share this post


Link to post
Share on other sites
On 2/21/2019 at 3:02 PM, imthatguyhere said:

Pastebin your "fn_storeVehicle.sqf" as well as your Client and Server RPTs from when you tried it.

Paste bin from where? what i need to do? please thanks

Share this post


Link to post
Share on other sites
12 hours ago, Fr3x said:

Paste bin from where? what i need to do? please thanks

That file I listed, and the entire Server RPT and Client RPT from when you tried it. Then link the 3 pastes here. Client RPTs are in "%localappdata%\Arma 3" and are timestamped based on when you ran ARMA 3.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...