Jump to content
kirky1423uk

problem adding lights on hatchback

Recommended Posts

hey up guys I think every thing right all other cop lights work aprt from the hatchback normal it works on sport any help cheers                                                                                   

fn_copLights.sqf

Share this post


Link to post
Share on other sites

when I press shift and L for beacon lights to come on they don't but they do on other vhecals its only the normal hactback that don't work                  https://pastebin.com/uy8B0un9                                                

 

                                                                                       

Share this post


Link to post
Share on other sites
1 hour ago, kirky1423uk said:

hey up fella just tried it and no luck I pressed shift an l its just head lights that work 

Pastebin your "fn_keyHandler.sqf" it sounds like you may not have added the class there so the file doesn't even get called in the hatchback.

Share this post


Link to post
Share on other sites
53 minutes ago, kirky1423uk said:

Yeah, you didn't add the class there. Change:

if (!(isNull objectParent player) && (typeOf vehicle player) in ["B_GEN_Offroad_01_gen_F","B_MRAP_01_F","C_SUV_01_F","C_Hatchback_01_sport_F","B_Heli_Light_01_F","B_Heli_Transport_01_F"]) then {

To:

if (!(isNull objectParent player) && (typeOf vehicle player) in ["B_GEN_Offroad_01_gen_F","B_MRAP_01_F","C_SUV_01_F","C_Hatchback_01_F","C_Hatchback_01_sport_F","B_Heli_Light_01_F","B_Heli_Transport_01_F"]) then {

and it should work (you are just adding C_Hatchback_01_F to the array.)

 

Here's a file with that change made: 

fn_keyHandler.sqf

  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×