Jump to content

[TUTORIAL][4.4R3] RYANTTS DYNAMIC MARKET SYSTEM


suffer4real
 Share

Recommended Posts

this didnt work on 4.4 for me stopped the mission running but when i followed the steps on the original github for it, it worked great other than the dynamic prices that it sets over ride the default prices that we set....

would make sense if it based around the prices we set in the config_vitems.hpp and then dynamically adjusted the prices based on whats selling more of and such rather than it just making up its own base prices unless they are being set some where in one of the supplied files that i aint seen.

Link to comment
Share on other sites

Ok i fixed my issue with the market menu not loading, basically in the guide on the github their was a step missing 

 

5.

now open your CfgRemoteExec.hpp and paste this right below the server functions

 

F(TON_fnc_playerLogged,SERVER) //DynMarket
F(TON_fnc_getUpdate,SERVER) //DynMarket
F(TON_fnc_changePrice, SERVER) //DynMarket
F(life_fnc_update,CLIENT) //DynMarket
  • Like 3
Link to comment
Share on other sites

21:20:28 Warning Message: File mpmissions\AltisLife.Altis\dialog\dynmarket_changeprice.hpp, line 81: .life_dynmarket_changeprice: Member already defined.
21:20:28 Warning Message: File mpmissions\AltisLife.Altis\dialog\dynmarket_prices.hpp, line 100: .life_dynmarket_prices: Member already defined.

 

Edited: Dw I'm retarded

Edited by STR1KEStudioz
im retarded xd
Link to comment
Share on other sites

6 hours ago, Kaiman™ * Publiclir.se said:

I have dubbel checked everything but i have a problem i do not have anything in my dynmarket in my database and i am getting this and i use Alits Life version is 4.5 if someone got it to work respond to this then :)

 

 

20170110042319_1.jpg

 

 

 

 

 

Means you have done something wrong. Check the github instructions for the script i believe there's a step in there that's not in this post. I'm gonna install this on my local server now so i'll let you know if i run into the same problem and how to fix it :)

  • Like 1
Link to comment
Share on other sites

@Kaiman™ * Publiclir.se Just installed it on my fresh 5.0.0 local server and it works just fine. Only think i did different from the original post here was remove the "getIcon" line in the functions.hpp and thats it.

Try following this tutorial instead: https://github.com/RyanTT/DynamicMarket/blob/master/DynMarket (ALTISLIFE 4)/Installation Instructions.txt

If you still can't make it work add me on steam and i'll try to help you out! :) http://steamcommunity.com/id/ikatzuki2/

Edited by Rasmus
  • Like 2
Link to comment
Share on other sites

On 1/10/2017 at 5:01 PM, Rasmus said:

@Kaiman™ * Publiclir.se problem has been solved! I hopped on teamviewer and helped him out! :)

The problem was the missing 

[] execVM "\life_server\Functions\DynMarket\fn_config.sqf";

in the Life_Server\init.sqf file.

Remember that line folks on 4.4 + :)

all though it wont update prices, neither will it update amount sold. Also it does not work for me:p

Edited by mur202
  • Like 1
Link to comment
Share on other sites

3 hours ago, Lathrix said:

All sorted

 

BUT! Now my spyglass says it has detected cheats on people except me ( They're not admins ) 
Ever since i installed this.. And its disabled on my server..

You gotta remove some extra stuff when you disable spyglass with Dynamic market. Hit me up on steam and i will help you out :)

  • Like 3
Link to comment
Share on other sites

Any reason you told us to put _geticon when there isn't such a file? Causes errors

Edit: After not being able to solve errors, I decided to remove the script, and I still get fn_Dynmarket_geticon.sqf not found wtf.

Please enlighten me.

Edit: Still no luck after 3 hrs of trying. I even went as far as to put a fresh functions.hpp in. This is getting confusing and annoying. All rpt says is "Warning Message: Script core\DynMarket\fn_DYNMARKET_getIcon.sqf not found" so doesn't help much.

Edit: Figured it out. Isn't TADST great? Told it to run one mission file, but it ran another +1 lmao

Edited by DaBombGamer
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.