Jump to content

EXTDB3 Not Loading In Any Of My Servers


Recommended Posts

Apologies for this, i've seen probably every thread on google for this problem but they mostly remain unanswered or they don't post logs or have a typo or something. Anyways, I followed this setup guide multiple times. 

  • First, I installed MariaDB. I set my password, let's call it codename 'potato'
  • Second, installed vc2015 x86 and x64 packs
  • Third, Opened heideSQL, as the host, root as the name, with the same 'potato' password I set in Mariadb.
  • I then opened Altislife.sql, replaced the 'changeme' password with my 'potato' password, selected the play button, all went well and says connected. I gave all of the user accounts global permissions and database permissions aswell for good measure.
  • Installed Arma3 server and followed copied the file order. 
  • Configured EXTDB3 
  • [altislife]
    IP =
    Port = 3306
    Username = root
    Password =  'potato'
    Database = altislife

Launch the server all fine, I can load in but as soon as it processes the mission file I get the "extdb could not load" black screen.

What i've tried: reinstalling vcredist, changing IP to "localhost" and the username to "arma3" , tried extdb3 1031, doublechecked extdb .dll files were in root arma 3 server folder. I've also tried the same on a takistan life server, and got the same exact problem with pretty much the same rpt logs. I am using tadst to launch, battleye is disabled. I have tried changing between the 32 bit and 64 bit arma 3 server.exe.

Kind of at a lost, would very much appreciate help.  I am willing to discord or teamviewer to get this working. 

 I've restarted this whole process atleast like 7 times now.


extDB3: https://bitbucket.org/torndeco/extdb3/wiki/Home
extDB3: Version: 1.033
extDB3: Windows Version
Message: All development for extDB3 is done on a Linux Dedicated Server
Message: If you would like to Donate to extDB3 Development
Message: https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=2SUEFTGABTAM2
Message: Also leave a message if there is any particular feature you would like to see added.
Message: Thanks for all the people that have donated.
Message: Torndeco: 18/05/15

Message: This version was modified and include some improvement
Message: The lib was recompiled using new version of TBBMalloc, Boost and MariaDB connector
Message: The worker threads limitation was removed
Message: Steez: 30/10/2020

extDB3: Found extdb3-conf.ini
extDB3: Detected 16 Cores, Setting up 6 Worker Threads
extDB3: Detected 16 Cores, Setting up 16 Worker Threads
extDB3: ...
extDB3: ...
extDB3: ...
extDB3: ...
extDB3: ...
extDB3: ...
extDB3: ...
extDB3: ...
extDB3: ...
extDB3: ...
extDB3: ...
extDB3: ...
extDB3: ...
extDB3: ...
extDB3: ...
extDB3: ...

The weird thing is, in the RPT logs it does show extdb3 connecting successfully 


CallExtension loaded: extDB3 (D:\SteamLibrary\steamapps\common\Arma 3 Server\@extDB3\extDB3_x64.dll) [extDB3 v1033 Windows]


"extDB3 Loaded"

but then this happens


Error: Object(2 : 660) not found

d:\bis\source\stable\futura\lib\network\networkserver.cpp NetworkServer::OnClientStateChanged:NOT IMPLEMENTED - briefing!

Mission id: cfc4097448a8138dd8c71abfa323b23f4d1f3574

CallExtension 'extDB' could not be found

"extDB: Version: "

"extDB: Error checked extDB/logs for more info"


Edited by redrooster
Link to comment
Share on other sites

  • 1 month later...

I am getting the following below, I saw someone else say it was their mission too with this error code, I have redownloaded the 5.0.0 framework twice and still no luck.  Could you upload the mission file that worked for you?

[19:12:28:668857 -06:00] [Thread 28192] extDB3: SQL: Initialized: Add Quotes around TEXT Datatypes mode: 2
[19:12:28:668984 -06:00] [Thread 28192] extDB3: SQL: Initialized: NULL = ""
[19:12:28:669008 -06:00] [Thread 28192] extDB3: Locked


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.