Jump to content

Recommended Posts

Hi! 

Im making my own Y- Menu like a phone and Ive made half of it already but it takes so fukin long to have to launch the server each time just to move an icon the have to keep launching and moving it to get it right.

I know there is a gui editor in arma 3 but is there a way I can get my phone image up and use it so that I know where Im drawing the buttons and stuff?

Anyone that can help I would greatly appreciate it!

Share this post


Link to post
Share on other sites
23 hours ago, MorgansFlaccidCock said:

Hi! 

Im making my own Y- Menu like a phone and Ive made half of it already but it takes so fukin long to have to launch the server each time just to move an icon the have to keep launching and moving it to get it right.

I know there is a gui editor in arma 3 but is there a way I can get my phone image up and use it so that I know where Im drawing the buttons and stuff?

Anyone that can help I would greatly appreciate it!

There is a way. When I get home I'll let you know how I did it

Share this post


Link to post
Share on other sites

Step 1. Go to the eden editor and create and save a new mission.

Step 2. Place your .paa picture in Documents\Arma 3\missions\YOUR_MISSION_FOLDER

Step 3. Back in the eden editor place a playable unit then start your mission.

Step 4. Once the mission loads press ESC and then on the bottom right of the debug console click the button called "GUI EDITOR".

Step 5. Right click somewhere on the screen and place an RscPicture

Step 6. Right click on the newly created RscPicture at the bottom there is a drop down list and change that to "Safezone"

Step 7. In the "Text:" section change that to the path of your texture in the mission file

EX. Mine is set to "gui\Phone_Main.paa" so this means that inside my mission folder i have another folder called "gui" and then inside that folder i have a image called Phone_Main.paa. So, if you are looking at the picture in the folder the actual directory is "Documents\Arma 3\missions\gui%20test.VR\gui\Phone_Main.paa" but since we are running the mission we only have to put "gui\Phone_Main.paa"

Step 8. Once you are done making the gui i always suggest saving it as an editable gui. Meaning you can reopen it later on. And to do this you press "CTRL + S" and then select "GUI Editor" and "Ok". 

Step 9. Then open a blank text document and then press "CTRL + V" and save it. It will paste something like this:

/* #Movojy
$[
	1.063,
	["Cellphone",[[0,0,1,1],0.025,0.04,"GUI_GRID"],0,0,0],
	[1200,"Phone",[1,"gui\Phone_Main.paa",["0.335 * safezoneW + safezoneX","0.115 * safezoneH + safezoneY","0.350625 * safezoneW","0.726 * safezoneH"],[-1,-1,-1,-1],[-1,-1,-1,-1],[-1,-1,-1,-1],"","-1"],[]]
]
*/

(To re-import into the GUI Editor copy the section between the /* and the */ with this copied reopen the GUI Editor.)

Step 10. To export the gui so it can be used in Altis press "CTRL + SHIFT + S" and that will save it in the right format for Altis Life.

  • Thanks 1

Share this post


Link to post
Share on other sites

Just add this to the top of a dialog file such as player_inv.hpp:

class HG: life_RscPicture
         {
         idc = -1;
         text = "YOUR IMAGE DIRECTORY";
         x = 0.255501 * safezoneW + safezoneX;
         y = 0.0716 * safezoneH + safezoneY;
         w = 0.485625 * safezoneW;
         h = 0.854 * safezoneH;
         };

You obviously change the x,y,w,h to what you want @Wackbatt

 

Share this post


Link to post
Share on other sites
1 hour ago, MorgansFlaccidCock said:

Hi! Thanks for the reply but it keeps saying Picture "gui\inventorymenu.paa" not found but it is there ive tried so many times its there

Do u have a file called gui in you mission file

Share this post


Link to post
Share on other sites

Hello there
   I added the phone picture.

How do I make these codes suitable for player_inv.hpp?

How can I activate the buttons I have added to the phone?

sample
License, Inventory, Bank, Settings and so on

Can you help me with this?

I want to learn how to write my own codes

Share this post


Link to post
Share on other sites

I know this is kinda off topic but I was doing the same thing until I came across a problem. For some reason I can't get any text to appear above the picture. It always appears behind the picture itself. Does anyone know why this is?

Share this post


Link to post
Share on other sites
On 2/27/2017 at 2:47 PM, Maihym said:

I know this is kinda off topic but I was doing the same thing until I came across a problem. For some reason I can't get any text to appear above the picture. It always appears behind the picture itself. Does anyone know why this is?

Make sure the text is in the controls class, not the background controls.

Share this post


Link to post
Share on other sites
5 hours ago, Ilusionz said:

Make sure the text is in the controls class, not the background controls.

And the picture in the background controls?

Share this post


Link to post
Share on other sites
Just now, Maihym said:

Awesome got it to work, thanks man.

No problem.

 

On 2/24/2017 at 5:34 PM, TulparHAN said:

I did not use png

I used paa.

Make sure your images follow a power of 2, otherwise Arma will have problems with it.

For example:

 

2x2, 4x4, 8x8, 16x16, 32x32, 64x64, 128x128, 256x256, 512x512, 1024x1024 ect. 

 

You can mix them up and do something like 1024x512.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.